Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Airplay ipv6 issue...
10-24-2012, 08:04 PM
Post: #1
Airplay ipv6 issue...
I have airplay issue since implementation of ipv6. I only have my iphone with ios6 to stream video and music. This is what I have tried:

Clean install
- see airplay icon but I cannot play anything. My iPhone icon turn orange.

Disable ipv6 on pi per other thread.
- iPhone icon is no longer displayed

Enable ipv6 on pi by deleting the file which disable ipv6
- airplay icon comes back ocassionally. Streams gets cut off part way then the icon disappear.

I know that my network is working because I can stream using July xbmc windows alpha to use airplay. I have wrt54g running ddwrt as my dhcp. Would a upgraded dhcp router to ipv6 fix the problem? Is there anything else I can do to fix this?

Thank you in advance.
Find all posts by this user
Quote this message in a reply
10-24-2012, 08:26 PM
Post: #2
RE: Airplay ipv6 issue...
libshairport does not work well with ipv6
Visit this user's website Find all posts by this user
Quote this message in a reply
10-30-2012, 12:11 AM (This post was last modified: 10-30-2012 12:12 AM by BuntuFreak.)
Post: #3
RE: Airplay ipv6 issue...
Have no clue about ipv6. I tried Airplay with iPhone and iPad. Each device thinks it is playing to the Pi, but the Pi not doing jack. Is Airplay functionality built into XBMC and will fix itself? Or it is something Raspbmc provides? Without Airplay, my PI is worthless to me.
Find all posts by this user
Quote this message in a reply
10-30-2012, 12:40 AM
Post: #4
RE: Airplay ipv6 issue...
If it is worthless, just send your pi over and I will pay for shipping. J/k

My problem solved. There is an issue with the airplay protocol not routing properly in my network. Even though I see the icon, it is actually not routed to my pi. From clean install and once I enabled the service in the setup, I am able to airplay.

I would suggest testing with other airplay device first, use a laptop with xbmc installed.
Find all posts by this user
Quote this message in a reply
10-30-2012, 01:25 AM
Post: #5
RE: Airplay ipv6 issue...
(10-30-2012 12:40 AM)Cheezer Wrote:  If it is worthless, just send your pi over and I will pay for shipping. J/k

Agreed, I'll happily take that Raspberry Pi if you don't want it Tongue
Find all posts by this user
Quote this message in a reply
10-30-2012, 02:59 AM (This post was last modified: 10-30-2012 03:01 AM by BuntuFreak.)
Post: #6
RE: Airplay ipv6 issue...
(10-30-2012 01:25 AM)DivinityCycle Wrote:  
(10-30-2012 12:40 AM)Cheezer Wrote:  If it is worthless, just send your pi over and I will pay for shipping. J/k

Agreed, I'll happily take that Raspberry Pi if you don't want it Tongue

Okay....please leave the jokes to me. I have Apple TV 3 which has airplay. Works beautifully, so dunno how it can be router issue. For PI + XBMC being better than ATV 3, it better do Airplay. If someone can please tell me if Airplay is XBMC functionality or PI functionality it would help.

If it is XBMC functionality I'll go ask my question somewhere else. Sometimes it plays for 5 seconds then stops. Other times iphone/ipad thinks Pi is playing the video but Pi is simply sitting there. So definitely not router blocking or it will not play period. That's my symptom regardless of whether I'm using Raspbmc, XBian (nothing sucks more intensely by the way) or OpenElec.
Find all posts by this user
Quote this message in a reply
10-30-2012, 11:33 AM (This post was last modified: 10-30-2012 11:35 AM by samburrows.)
Post: #7
RE: Airplay ipv6 issue...
(10-30-2012 02:59 AM)BuntuFreak Wrote:  
(10-30-2012 01:25 AM)DivinityCycle Wrote:  
(10-30-2012 12:40 AM)Cheezer Wrote:  If it is worthless, just send your pi over and I will pay for shipping. J/k

Agreed, I'll happily take that Raspberry Pi if you don't want it Tongue

Okay....please leave the jokes to me. I have Apple TV 3 which has airplay. Works beautifully, so dunno how it can be router issue. For PI + XBMC being better than ATV 3, it better do Airplay. If someone can please tell me if Airplay is XBMC functionality or PI functionality it would help.

If it is XBMC functionality I'll go ask my question somewhere else. Sometimes it plays for 5 seconds then stops. Other times iphone/ipad thinks Pi is playing the video but Pi is simply sitting there. So definitely not router blocking or it will not play period. That's my symptom regardless of whether I'm using Raspbmc, XBian (nothing sucks more intensely by the way) or OpenElec.

My RaspBMC running RC5 works perfectly using Airplay from either an iPhone 4, iPhone 4S or iPad3. Currently running it blind (no HDMI) into my living room Amp and it hasn't crashed once in 8 days. Everytime I select audio from my iPad / iPhone it springs to life and starts playing beautifully.

Have also tested with HDMI into the TV this weekend and it streams YouTube video from TubeBox App perfectly.

I cannot, therefore, see how this is an issue with the Pi, XBMC or RaspBMC.

(10-30-2012 12:11 AM)BuntuFreak Wrote:  Have no clue about ipv6. I tried Airplay with iPhone and iPad. Each device thinks it is playing to the Pi, but the Pi not doing jack. Is Airplay functionality built into XBMC and will fix itself? Or it is something Raspbmc provides? Without Airplay, my PI is worthless to me.

To be a touch more helpful to you:

1) Are you running RC5? Previous builds didn't support Airplay.
2) Do you have a decent power supply?
3) Have you checked your Audio Output settings?

(3) may seem a stupid question but you'd be amazed how many people have their Pi devices plugged into an amp using the 3.5mm jack but still have audio out settings set to HDMI.
Find all posts by this user
Quote this message in a reply
10-30-2012, 12:32 PM
Post: #8
RE: Airplay ipv6 issue...
(10-30-2012 11:33 AM)samburrows Wrote:  To be a touch more helpful to you:

1) Are you running RC5? Previous builds didn't support Airplay.
2) Do you have a decent power supply?
3) Have you checked your Audio Output settings?

This may seem a stupid question but you'd be amazed how many people have their Pi devices plugged into an amp using the 3.5mm jack but still have audio out settings set to HDMI.

Yes - running RC5 and yes, I have turned on Airplay delivery.
My power supply is 700mA / 5V. It is fine.
Audio Output settings - I didn't touch them. I'm using HDMI direct to TV no receiver in the middle.
Find all posts by this user
Quote this message in a reply
10-30-2012, 02:35 PM
Post: #9
RE: Airplay ipv6 issue...
Airplay is a function which is part of xbmc. That is why I suggest using other xbmc setup to check.
I have powerline connecting two wireless routers. For me, it is the powerline that is causing the problem. The airplay won't route properly. FYI.
I suggest login into pi and disable ipv6. Ipv6 was giving me wrong signals. Seeing airplay icon but airplay was not working.

Hope it helps.
Find all posts by this user
Quote this message in a reply
10-31-2012, 02:09 AM (This post was last modified: 10-31-2012 02:10 AM by BuntuFreak.)
Post: #10
RE: Airplay ipv6 issue...
(10-30-2012 02:35 PM)Cheezer Wrote:  Airplay is a function which is part of xbmc. That is why I suggest using other xbmc setup to check.
I have powerline connecting two wireless routers. For me, it is the powerline that is causing the problem. The airplay won't route properly. FYI.
I suggest login into pi and disable ipv6. Ipv6 was giving me wrong signals. Seeing airplay icon but airplay was not working.

Hope it helps.

Hmm....

My router is Wireless G (I know I suck). But ATV 3 has wireless N. With the PI I'm using Wireless G Client Bridge (Linksys Router pimped with DD-WRT). I'll get a Wireless N USB and try with the Pi to see if it makes a difference.

As I said I tried all 3 Raspbmc, XBian, Openelec. Not sure if they share same XBMC version, I think not. Same exact problem. If the issue is network related I feel good about finding and fixing it. If XBMC related, I guess I have to wait till the feature matures.

Thanks. You gave me something to try. Now can you please tell me how I disable IPV6. I know how to SSH into the PI, but what do I do after that?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Sponsored Advertisement