Vero is OSMC's new flagship device. Find out more here.

Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multichannel 5.1 no longer works after update
11-05-2013, 03:41 PM (This post was last modified: 11-05-2013 03:41 PM by marctwo.)
Post: #31
RE: Multichannel 5.1 no longer works after update
Perhaps, but I have it running direct from the Pi into my AVR via HDMI.

I shall try tvservice -a and report back.
Find all posts by this user
Quote this message in a reply
11-05-2013, 04:26 PM
Post: #32
RE: Multichannel 5.1 no longer works after update
(11-05-2013 03:06 PM)marctwo Wrote:  This sounds to me like I should be getting multi-channel PCM output from my AAC 5.1 files. My Yamaha AVR does support this but only receives stereo. I am not sure what you mean by 'set multichannel'. Is this simply setting any speaker setup > 2.0?

Post your xbmc.log file (one pastebin type site) after trying to play that file.

Note, if the source file is only stereo, and 5.1 speakers are enabled, we just output stereo (intention is to allow receiver to do it's clever upmixing, although this may change as it hinders "stream silence").
Find all posts by this user
Quote this message in a reply
11-05-2013, 05:12 PM
Post: #33
RE: Multichannel 5.1 no longer works after update
(11-05-2013 04:26 PM)popcornmix Wrote:  
(11-05-2013 03:06 PM)marctwo Wrote:  This sounds to me like I should be getting multi-channel PCM output from my AAC 5.1 files. My Yamaha AVR does support this but only receives stereo. I am not sure what you mean by 'set multichannel'. Is this simply setting any speaker setup > 2.0?

Post your xbmc.log file (one pastebin type site) after trying to play that file.

Note, if the source file is only stereo, and 5.1 speakers are enabled, we just output stereo (intention is to allow receiver to do it's clever upmixing, although this may change as it hinders "stream silence").

The source shows as 5.1 AAC in XBMC. I'll fiddle with the settings and post the log if needed. Thanks for the reply.
Find all posts by this user
Quote this message in a reply
11-05-2013, 05:58 PM
Post: #34
RE: Multichannel 5.1 no longer works after update
Can someone also report the output of
Code:
vcgencmd version
(or provide an xbmc.log file which includes it)
Find all posts by this user
Quote this message in a reply
11-05-2013, 08:15 PM
Post: #35
RE: Multichannel 5.1 no longer works after update
hi

The same that another guys, with las update decode 5.1 is broken.

My solution, downgrade to nightly20131030, now works, but only with 2 chanels.

This is my logs, popcornmix, if you need more data, please request me:

pi@raspbmc:~$ cat /scripts/upd_hist/build_info
raspbmc-rls-1.0-hardfp-b20130208-u20131101
pi@raspbmc:~$ tvservice -a
PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 24 bits.
pi@raspbmc:~$ vcgencmd version
Oct 18 2013 16:04:29
Copyright © 2012 Broadcom
version dbda126981820ea5681263042435388dddf65131 (tainted) (release)
pi@raspbmc:~$
Find all posts by this user
Quote this message in a reply
11-05-2013, 08:33 PM (This post was last modified: 11-05-2013 08:35 PM by popcornmix.)
Post: #36
RE: Multichannel 5.1 no longer works after update
(11-05-2013 08:15 PM)alucine Wrote:  pi@raspbmc:~$ vcgencmd version
Oct 18 2013 16:04:29
Copyright © 2012 Broadcom
version dbda126981820ea5681263042435388dddf65131 (tainted) (release)

Ah - that's a problem. As I told Sam on the 28th:
"You need latest firmware from 'next' tree for multichannel audio to work."

If you want this to work, download:
https://github.com/Hexxeh/rpi-firmware/r...tart_x.elf
https://github.com/Hexxeh/rpi-firmware/r...ixup_x.dat

and replace the similarly named files on the FAT partition of sdcard.
Find all posts by this user
Quote this message in a reply
11-05-2013, 09:17 PM
Post: #37
RE: Multichannel 5.1 no longer works after update
(11-05-2013 08:33 PM)popcornmix Wrote:  
(11-05-2013 08:15 PM)alucine Wrote:  pi@raspbmc:~$ vcgencmd version
Oct 18 2013 16:04:29
Copyright © 2012 Broadcom
version dbda126981820ea5681263042435388dddf65131 (tainted) (release)

Ah - that's a problem. As I told Sam on the 28th:
"You need latest firmware from 'next' tree for multichannel audio to work."

If you want this to work, download:
https://github.com/Hexxeh/rpi-firmware/r...tart_x.elf
https://github.com/Hexxeh/rpi-firmware/r...ixup_x.dat

and replace the similarly named files on the FAT partition of sdcard.

Sorry but not works, 5.1 movies are 2.1 Sad

pi@raspbmc:~$ tvservice -a
PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 24 bits.
pi@raspbmc:~$ vcgencmd version
Nov 4 2013 18:33:09
Copyright © 2012 Broadcom
version 226c66e13d6e72a6a0d1831bee5c6ea345325ac4 (clean) (release)
Find all posts by this user
Quote this message in a reply
11-05-2013, 09:32 PM
Post: #38
RE: Multichannel 5.1 no longer works after update
@alucine
Do you have an AVR that supports multichannel PCM and are you connecting directly to it from Pi?

Raspbmc troubleshooting and req info for support
Raspbmc How-To´s
R-Pi troubleshooting
Find all posts by this user
Quote this message in a reply
11-05-2013, 10:13 PM
Post: #39
RE: Multichannel 5.1 no longer works after update
(11-05-2013 09:32 PM)miappa Wrote:  @alucine
Do you have an AVR that supports multichannel PCM and are you connecting directly to it from Pi?

Before of updates 5.1 movies play like 5.1, now after update 2.1, after downgrade nightly 20131030 2.1

About my configuration, raspberry -> hdmi -> samsung 55F8000 -> optical cable -> onyko avr

After update in system - audio, only appear hdmi or analog, before has more options.

Setting tv or avr not is change, only raspberry is update Sad
Find all posts by this user
Quote this message in a reply
11-05-2013, 10:39 PM
Post: #40
RE: Multichannel 5.1 no longer works after update
I always thought optical couldn't do more than 2 channels PCM anyway, even when your multichannel PCM was working (out of the pi) I'm guessing your TV is downmixing, then your avr was upmixing.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Sponsored Advertisement